Runtime Error 9

View previous topic View next topic Go down

Runtime Error 9

Post  peterhag on Sun Sep 06, 2009 12:55 pm

When using Tune Vnav and airac cycle 0909 I get a Runtime Error when clicking the Set apt config. Any idea what might be wrong?

peterhag

Posts : 1
Join date : 2009-09-06

View user profile

Back to top Go down

Runtime error 9

Post  Admin on Wed Sep 09, 2009 3:49 pm

Hi Peter,

I found the problem. The AIRAC is bad formatted, I have informed Navigraph about the issue.

Here is the link to their forum with the posted issue:

http://forum.navigraph.com/forum/default.aspx?g=posts&m=5580&#5580

An AIRAC revision will be made to be downloaded from their site.

Thanks for the info.

Regards,

Valerian

Admin
Admin

Posts : 14
Join date : 2008-03-16

View user profile http://tunevnav.subject-expert.com

Back to top Go down

Hope its ok to report another Error 9 with AIRAC 1007

Post  scottgr on Thu Jul 08, 2010 12:53 am

To repro, use B738 aircraft and choose KELP airport, click "Get APT"
This has been happening for quite a few AIRAC versions but the one I'm currently using is 1007.

scottgr

Posts : 1
Join date : 2010-07-08

View user profile

Back to top Go down

Hope its ok to report another Error 9 with AIRAC 1007

Post  Admin on Thu Jul 08, 2010 11:02 am

Thanks for posting this new error.

I will search the cause and I will inform the Navigraph guys to make the proper adjustments.

The issue here is that, initially they had the data base for TuneVNAV structured in a way that TuneVNAV could get the info form it as needed.
For no reason they have made some minor changes into their structure so TuneVNAV can't get the data as before. Therefore it crashes...
I have identified most of the issues and asked them to fix them. Some were fixed but it seems that some... not.

I'll let you know ASAP.

Cheers,

Valerian

Admin
Admin

Posts : 14
Join date : 2008-03-16

View user profile http://tunevnav.subject-expert.com

Back to top Go down

Runtime error too

Post  dan on Fri Sep 24, 2010 2:32 am

Hi! when I type EGPB (sumburgh) and hit the get airport button, I get "runtime error 9 subscript out of range". Evil or Very Mad Another airac problem? I'm using airac 1009.

Cheers

Dan

dan

Posts : 2
Join date : 2010-09-24

View user profile

Back to top Go down

AIRAC FIX DIY

Post  Admin on Sat Sep 25, 2010 1:44 pm

This error is caused by an AIRAC issue.

Here is how to fix it, and any other that may arrise wich crash TuneVNAV while loading an APT.

Do the following steps:

1.Go to TuneVNAV Pro3 SIDSTARS folder:
On 32bits OS:
C:\Program Files\TuneVNAV Pro3\FMS_DATA\SIDSTARS
On 64bits OS:
C:\Program Files (x86)\TuneVNAV Pro3\FMS_DATA\SIDSTARS

2. Look for the faulty APT ICAO name (ie. EGPB). It is a txt file (EGPB.txt)
3. Double click on it to open it with notepad
4. Look for the following lines:

SID
ENDSIDS

5. Add bellow these lines the following lines that are missing but they should be:

STARS
ENDSTARS

The final result should look like this:

SID
ENDSIDS

STARS
ENDSTARS


(APPROACHES is the line that follows)

IMPORTANT : Make sure you have a empty new line between each group of lines.

6. Save

That is all. Now you can load your APT.

Regards,

Valerian E Partenie
TuneVANV Pro3 author

Admin
Admin

Posts : 14
Join date : 2008-03-16

View user profile http://tunevnav.subject-expert.com

Back to top Go down

All Ok

Post  dan on Sun Sep 26, 2010 12:38 pm

That did the trick! Very Happy

Thanks for your quick support. Love using your program!

regards,
Dan

dan

Posts : 2
Join date : 2010-09-24

View user profile

Back to top Go down

Re: Runtime Error 9

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum